terça-feira, 28 de junho de 2011

Ex.08 - Números pares e ímpares de um vetor

Escreva um algoritmo que leia e mostre um vetor de 20 elementos inteiros. a seguir, conte quantos
valores pares e ímpares existem no vetor.

Entendendo...

Vamos criar um vetor com 20 posições e ler cada uma delas, e depois mostrar na tela, sem novidades =)

Teremos uma condição onde validaresmo os números pares e impares, pegaremos o resto da divisão do número lido, se for = zero será par senao impar.

Muito Semelhante ao Ex. 05.

Uma possível solução:

algoritmo "Ex.08 - Números pares e ímpares de um vetor"

// Autor :Eduardo V. de Souza
// Data : 28/06/2011

var

//Declaração das variáveis
vet:vetor[1..20] de inteiro
i,cont_par,cont_imp:inteiro

inicio

//inicializando os contadores
cont_imp<-0
cont_par<-0

escreval("Digite todos os números")

para i de 1 ate 20 faca
//lendo cada elemento do vetor
leia(vet[i])
//aqui todo o calculo, se nao existir resto na divisao = par
//senao impar
se (vet[i]%2) = 0 entao
//se par, o contador recebe seu valor + 1
cont_par<-cont_par+1
senao
//se par, o contador recebe seu valor + 1
cont_imp<-cont_imp+1
fimse
fimpara

// eu sei que bagunça mas estou mostrando na tela todos os lidos
para i de 1 ate 20 faca
escreval("Elemento nº ",i," do vetor = ",vet[i])
fimpara

// e finalmente mostrando o resultado
escreval("O total de números pares lidos foi ",cont_par)
escreval("O total de números ímpares lidos foi ",cont_imp)

fimalgoritmo

Em execução:



8 comentários:

  1. bom p fazer tabela zebrada. =D

    ResponderExcluir
  2. obrigado por sua aula. é demais. nao deixe de fazer. nós da fatec pe agradessemos.

    ResponderExcluir
    Respostas
    1. uhahuahu recentemente fui em PE muito bom olinda =)

      Excluir
  3. Bom dia sei que pode ser meio estranha minha perguntar mais por que cont_par<-cont_par+1 ?

    ResponderExcluir
    Respostas
    1. Assim, usei uma possivel solução criar um contador para os numeros impares e um ocntador para os pares, esse é o contador dos pares, nos precisamos fazer esse controle para saber quando que o vetor ficou completo... se sabemos que o vetor tem o tamanho 5, entao todas vez que esse contador estiver com o valor 5, ele imprime o vetor =P...

      sei que faz tempo, vc deve ja ter feito a muitoooo tempo.. mas achei q ia ser bom respoder

      Excluir
  4. Tem como me ajudar com esse aqui?

    "Escreva um algoritmo que leia um vetor de 100 posições e mostre-o ordenado em ordem crescente."

    ResponderExcluir
  5. TOP
    algoritmo "semnome"
    // Função :
    // Autor : Adriano Cabra
    // Data : 14/05/2014 21:36
    // Seção de Declarações
    var
    n:vetor[1..20] de real
    qtd_par,qtd_imp:inteiro
    i:inteiro
    inicio
    qtd_imp<-0
    qtd_par<-0
    para i de 1 ate 20 faca
    escreval("informe os valores")
    leia (n[i])
    se (n[i] mod 2) = 0 entao
    qtd_par<-qtd_par+1
    senao
    qtd_imp<-qtd_imp+1
    fimse
    fimpara
    escreval("O total de números pares lidos foi ",qtd_par)
    escreval("O total de números ímpares lidos foi ",qtd_imp)

    fimalgoritmo

    ResponderExcluir