sexta-feira, 24 de junho de 2011

Ex. 05 - Número é par ou ímpar, e se é positivo ou negativo

Faça um algoritmo que leia um nº inteiro e mostre uma mensagem indicando se este número é par ou ímpar, e se é positivo ou negativo.

Entendendo...

Aqui teremos que ler um número e verificar se ele e maior ou menor que zero, e depois verificar se ele e par ou impar, verificaremos se ele e par ou impar pegando o resto da divisão por 2 (mod), se o resultado for zero então ele é par, senao é impar.

Uma possível Solução:

algoritmo "Número é par ou ímpar, e se é positivo ou negativo"

// Autor : Eduardo V. de Souza
// Data : 24/06/2011

var

num: inteiro

inicio

escreval("Digite o número")
leia(num)//Lendo a variável


//verificando o resto da divisão por 2, se = 0 par senao impar
se (num % 2) = 0 entao
escreval("O número é par")
senao
escreval("O número é impar")
fimse

//verificando se é maior ou = 0
// vou considerar aqui zero como numero positivo
se (num >= 0) entao
escreval("O número é positivo")
senao
escreval("O número é negativo")
fimse

fimalgoritmo

Em execução:

10 comentários:

  1. Obrigado cara eu consegui, mas
    oque significa o sinal % ?

    ResponderExcluir
    Respostas
    1. % em Pascal seria ''MOD'' esse comando executa a divisão e motra o resto da divisão:

      Ex: 5 Dividido por 2 = 2,5 O ''MOD'' mostra o 5.

      Excluir
  2. eu tbm consegui , mas nao entendi o "%"
    o que significa o % ??

    ResponderExcluir
    Respostas
    1. Significa módulo

      Excluir
    2. % representa o resto da divisão, a partir daí você saberá se o numero é ímpar ou par

      Excluir
  3. Ola,
    na verdade o proprio código já explica a duvida de vocês,

    //verificando o resto da divisão por 2, se = 0 par senao impar

    se (num % 2) = 0

    ou seja, vamos supor que a variavel num esteja com o valor 4.

    quando dividirmos 4/2 e nao RESTAR NADA, ai ele e par
    4/2 resto 2
    2/2 resto 0 = par

    vamos supor que a variavel num esteja com o valor 5.
    5/2 resto 3
    3/2 resto 1
    como 1 não da divisao inteira por 2 paramos a divisao e concluimos que é um numeno impar.


    A % é o famoso "mod" ou resto de divisao.

    Espero ter ajudado.


    ResponderExcluir
  4. Nem meu Professor Sabia desse % , so usava MOD

    ResponderExcluir
  5. Fiz assim: se (num % 2) = 0
    mas deu errado, então fiz dessa forma: se(num %2==0)
    e deu certo!!!

    ResponderExcluir
  6. Posso colocar o sinal de barra " / " no lugar do de porcentagem " % " ?

    ResponderExcluir